new 79 qt 50 fuel pet cock not working ?

General discussion forum for repairing and riding mopeds

Moderators: ItsLookingUp, pehuskey, Tab, mountainmoped, JD, John

new 79 qt 50 fuel pet cock not working ?

Postby 1902bob » Wed Oct 02, 2013 4:24 pm

Installed a new pet cock on my qt 50. When I turn it on nothing comes out. If I take the fuel line off the carberator then gas come down the line. tighten it back up and no gas comes down the line. Same thing with the gas cap off the tank. Hoping someone will have some knowledge on this....I'm stumped. Thanks in advance!
how do I replace the oil indicator light for my qt 50?
1902bob
Net Rider
 
Posts: 9
Joined: Mon Aug 12, 2013 12:33 pm
Location: Superior, Wi

re: new 79 qt 50 fuel pet cock not working ?

Postby John » Thu Oct 03, 2013 7:36 am

Works on vacuum maybe?
John

"Plan your life like you will live forever, and live your life like you will die the next day!"
User avatar
John
Master Regional Rider
 
Posts: 4444
Joined: Tue Nov 18, 2003 9:52 pm
Location: Caledonia, Ontario, Canada

re: new 79 qt 50 fuel pet cock not working ?

Postby 1902bob » Thu Oct 03, 2013 1:33 pm

Appreciate the input John but it isn't vacuum operated
how do I replace the oil indicator light for my qt 50?
1902bob
Net Rider
 
Posts: 9
Joined: Mon Aug 12, 2013 12:33 pm
Location: Superior, Wi

re: new 79 qt 50 fuel pet cock not working ?

Postby John » Thu Oct 03, 2013 7:26 pm

Well is there a internal screen on the banjo. Needle stuck, needle inlet fouled with rotten rubber tip jammed in. Shear guess work when not in hand! Maybe you just need a new carb?
John

"Plan your life like you will live forever, and live your life like you will die the next day!"
User avatar
John
Master Regional Rider
 
Posts: 4444
Joined: Tue Nov 18, 2003 9:52 pm
Location: Caledonia, Ontario, Canada


Return to Moped Riders

Who is online

Users browsing this forum: Bing [Bot] and 2 guests