Got the last "Ike's Bikes" moped running

General discussion forum for repairing and riding mopeds

Moderators: ItsLookingUp, pehuskey, Tab, mountainmoped, JD, John

Got the last "Ike's Bikes" moped running

Postby Tab » Sat Oct 26, 2013 11:15 pm

Well, I just finished getting the very last moped from Ike's Bikes up and running. This was the last of the three "garage queen" Puch Magnums that he had gotten in the early 2000's. After a good tank clean (it was more dirty than anything) and a complete fuel and oil line replacement, it started right up. But, those Puch 2-speed shift dampeners had deteriorated from age and had to be replaced. With that done, the 43 mile Magnum rides and shifts like brand new. I guess the engine still needs to be broken in! One thing I don't understand is the 1HP designation on the engine cover. I know that this bike was never modified, but it runs right up to 29 mph. Similar to a 1.5 or 2HP model.
Anyway, here's a quick video of it running. I feel guilty even starting it.
http://youtu.be/CBhgOEsB4BU
User avatar
Tab
Master Regional Rider
 
Posts: 2584
Joined: Sat Nov 15, 2003 6:55 pm
Location: Nicholasville, KY

re: Got the last "Ike's Bikes" moped running

Postby wardie » Tue Oct 29, 2013 9:48 pm

Ike and Ike's Bikes may they both live long in our memories. Thanks Tab..Wardie
wardie
Regional Rider
 
Posts: 717
Joined: Tue Dec 28, 2004 11:46 pm
Location: Youngstown,Ohio


Return to Moped Riders

Who is online

Users browsing this forum: Bing [Bot] and 5 guests