New to the forum

General discussion forum for repairing and riding mopeds

Moderators: ItsLookingUp, pehuskey, Tab, mountainmoped, JD, John

New to the forum

Postby cvisinho » Wed Mar 05, 2014 4:05 pm

Good afternoon all,

Ive been reading on this forum for a bit as a non member so i wanted to introduce my peds.

I have an 87 qt50 with some work done.
Also, a 78 batavus starflite (25mph) headache im currently working on. About 98% restored and everything works except spark off the stator.

couple pics attached

cheers
You do not have the required permissions to view the files attached to this post.
cvisinho
Net Rider
 
Posts: 1
Joined: Wed Mar 05, 2014 9:18 am
Location: Rhode Island

re: New to the forum

Postby don45640 » Sat Mar 22, 2014 8:36 pm

Great bikes! I have a Bat Starflite,but haven't run it. You say you have no charging current from the stator? Probably a solution on this forum if you do a search. I'd be looking for a bad rectifier,probably. don-ohio (:^)
`Ped `til yer RED!!!' don-ohio (:^)
don45640
Net Rider
 
Posts: 18
Joined: Mon Aug 08, 2011 1:24 am
Location: Jackson,OH

re: New to the forum

Postby bryanofmyrons » Sun Mar 23, 2014 11:22 am

Very nice QT! I ran one nearly every day for about 5 years, they are quite interesting machines. By 'some work' do you mean kitted or by massaging the stock barrel? I see the pipe and it almost looks as if those are 16s laced to the hubs
Bryan...a Myron's Maniac since Ride #3
bryanofmyrons
Distinguished Rider
 
Posts: 206
Joined: Fri Dec 24, 2004 11:02 pm
Location: SoCal


Return to Moped Riders

Who is online

Users browsing this forum: No registered users and 3 guests

cron